Back to overview
Downtime
Web Downloads Unavailable
Mar 12 at 10:38pm CDT
Affected services
Web Downloads API
Resolved
Mar 13 at 06:14am CDT
The issue has been confirmed resolved, and operational for a few hours now. Thanks for your patience!
Affected services
Created
Mar 12 at 10:38pm CDT
Our systems hosting this service are offline, and are waiting for the hosting provider to resolve the issue.
Affected services