Back to overview
Usenet degredation
Feb 13, 2026 at 6:22pm UTC
Affected services
Usenet Service
Resolved
Feb 13, 2026 at 6:22pm UTC
Usenet downloads are degraded, the team is investigating.
EDIT: Fix is live.
Affected services
Resolved
Feb 13, 2026 at 6:22pm UTC
Usenet downloads are degraded, the team is investigating.
EDIT: Fix is live.
Affected services