Back to overview
Degraded
Usenet file playback via addons
Jan 07 at 08:22am CST
Affected services
Stremio Addon
Resolved
Jan 07 at 05:54pm CST
This issue has been resolved. Thanks!
Affected services
Created
Jan 07 at 08:22am CST
We're investigating reports of users unable to play Usenet files on our Stremio add-on. This does not appear to affect other types of transfers and transfers requested via the dashboard.
Affected services