Back to overview
Degraded
Degraded Download Speeds
Dec 04 at 06:35pm CST
Affected services
WebDAV
Resolved
Dec 04 at 10:15pm CST
We have identified the issue, to prevent it happening in the future. Everything should be back to normal.
Affected services
Created
Dec 04 at 06:35pm CST
A few of our CDNs are degraded due to an upstream issue. This includes WNAM, CNAM, SNAM, ENAM, and LATM. We will update when this issue has been resolved.
Affected services