Back to overview
Degraded
Hosters availability
Oct 09 at 09:08am CDT
Affected services
Web Downloads API
Resolved
Oct 10 at 04:22pm CDT
This issue has been resolved. We are monitoring hosters.
Affected services
Created
Oct 09 at 09:08am CDT
We are investigating reports of certain hosters returning errors when attempting to download from the dashboard.
Please keep an eye for updates.
Affected services