Back to overview
Degraded
Usenet outage.
Sep 12 at 04:52pm CDT
Affected services
Usenet Service
Updated
Sep 13 at 10:13am CDT
We're continuing to work through the backlog created by the outage. Please keep an eye on your dashboard notifications for download completions.
Affected services
Updated
Sep 13 at 08:29am CDT
We have begun to see service restoration and the team continues to monitor.
Affected services
Created
Sep 12 at 04:52pm CDT
We are currently investigating an outage affecting Usenet downloads. During this time Usenet articles may be slow to download or fail to download.
Affected services