Back to overview
Downtime

Upstream provider power failure.

Aug 05 at 11:56am CDT
Affected services
Web Downloads API
Usenet Service

Resolved
Aug 05 at 01:43pm CDT

Services are restarting to restore.

We are continuing to monitor.

Created
Aug 05 at 11:56am CDT

Usenet and web downloads are unavailable due to a power outage with an upstream provider.

Further updates to follow. No ETR.